Service Outage
Incident Report for Confection
Resolved
We've resolved this issue and are monitoring for any additional outages.

===== What happened?

On 8/16, we released a new version of Confection. It included a streamlined, system-wide billing update. An error in this update resulted in total system outage. We've resolve the bug, released a fix, and now the system is operating normally again.

===== What's the impact?

From approximately 1:12 PM (Pacific Time) on August 16, 2022 until approximately 1:45 PM (Pacific Time) on August 17, 2022, no data was written to customer accounts.

===== What are you doing to make this right?

To compensate customers for 24 hours of data loss, we've credited all paid accounts $5. This credit will appear on your September charge. For example, if you pay $20/mo to use Confection, your next charge will be $15.

We've also reset all billable activity for the month of August. Any events written before August 16 are on us. For the rest of the month, all users will enjoy a full month's worth of credits. For example, if you're on a 20,000 pageview plan -- and you wrote 20,000 pageviews before August 16 -- you can now write an additional 20,000 events by September 1st.

That's 40,000 total events for no extra charge.

If you'd like more information, please email us at get@confection.io
Posted Aug 17, 2022 - 21:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2022 - 16:21 UTC
Update
We are continuing to investigate this issue.
Posted Aug 16, 2022 - 23:33 UTC
Update
We are continuing to investigate this issue.
Posted Aug 16, 2022 - 21:19 UTC
Investigating
We're currently investigating a service outage.
Posted Aug 16, 2022 - 21:18 UTC
This incident affected: Application Core (Substation, Transmission API, Dashboard).